Build directory suddenly missing in deployment (error with prism?)

default discord avatar
4 weeks ago

Hey, going crazy with this one—is there anything that changed in the last 3 — 4 days that could be causing the


directory to be missing after running

yarn install && yarn build

in my Dockerfile? It's running on GCP Build and successfully deployed a few days ago. It builds fine locally and outputs the


dir. The build stage doesn't fail, but when the runtime stage goes to copy


from the builder stage

The only difference in my build logs are some complaints saying "you may need an appropriate loader" and Error:

[1mERROR in ./node_modules/prismjs/components/prism-markdown.js 117:18

I've tried rolling back to payload 2.0.10, 11, 12, and 13 without luck. I'm pretty sure my last successful deploy was on 2.0.11 so I'm doubly confused what might have changed. Thank you for any help!

Just fixed, it's an issue with Lexical. I added Slate back in and removed the


package and the build worked and deployment went through

Realizing now that Lexical is still in beta...I'll see if there's somewhere I should add an issue for thi

Being solved by @alessiogr
    Open the post
    Continue the discussion in Discord
    Like what we're doing?
    Star us on GitHub!


    Connect with the Payload Community on Discord



    Can't find what you're looking for?

    Get help straight from the Payload team with an Enterprise License.